bytran source code

Bytran version 1.3 and below would no longer function due HITRANOnline switch to secure HTTP in the Fall of 2018.   Version 1.0 of bytran was also affected by slight changes in the HITRANOnline TIPS file format made in the summer of 2017.   It should still be possible however to also compile bytran versions 1.1 and above to work with the secure connection now requred to access HITRANOnline.   In order to do so one needs to modify all HITRANOnline related web addresses in bytran to have a secure conneciton prefix HTTPS instead of the previously used HTTP (these addresses to be modified are located in the bytrancore.cpp source file).

Archive format bytran 1.3.2 bytran 1.3.1 bytran 1.3 bytran 1.2 bytran 1.1 bytran 1.0
ZIP ZIP file ZIP file ZIP file ZIP file ZIP file ZIP file
TAR TAR file TAR file TAR file TAR file TAR file TAR file

compiling bytran

The table below lists versions of Qt used to compile different versions of bytran under different operating systems.   To compile bytran under Ubuntu Linux, the mesa-common-dev and libglu1-mesa-dev libraries should be installed as described here and in the official guide on Qt installation on Ubuntu.

Operating system bytran 1.3.X bytran 1.2 bytran 1.1 bytran 1.0
Android 5.11.1 5.11 Beta 4 5.9.1 5.6.1-1
iOS 5.9.5 5.9.5 5.7.1 5.6.1-1   or   5.7.0
Windows Phone,
Universal Windows Platform (UWP) – ARM
5.11.1
(MSVC 2017)
5.11 Beta 4
(MSVC 2017)
5.7.1
(MSVC 2013)
5.6.1-1   or   5.7.0
(MSVC 2013)
Raspbian 5.9.6 5.9.6 Beta 5.9.0 Beta 3
Linux 5.9.6 5.9.5 5.9.0 Beta 3 5.6.1-1   or   5.7.0
MacOS 5.9.5 5.9.5 5.9.1 5.6.1-1   or   5.7.0
Universal Windows Platform (UWP) – x64 5.11.1
(MSVC 2017)
5.11 Beta 4
(MSVC 2017)
Windows x86 (32 bit) 5.11.1
(MSVC 2015)
5.10.1
(MSVC 2015)
5.9.1
(MinGW)
5.6.1-1   or   5.7.0
(MinGW)

www.bytran.org -|- 2018     To report a bug or suggest a feature please email us:  bytran@bytran.org